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Information in this document is subject to change without notice. The software described in this document is 

furnished under a license agreement or nondisclosure agreement.  

The software may be used or copied only in accordance with the terms of those agreements.  

All rights reserved. No part of this publication may be reproduced, stored in a retrieval system, or transmitted 

in any form or any means electronic or mechanical, including photocopying and recording for any purpose 

other than the purchaser’s personal use without the written permission of IDBS.  

 

The names of actual companies and products mentioned in this document may be trademarks of their 

respective owners.  

IDBS accepts no responsibility or liability for any errors or inaccuracies that may appear in this 

documentation.  
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Introduction 

After installation of XLfit, if Excel is loaded and the XLfit toolbar (Office 2003) or ribbon (Office 2007/2010) 

does not appear, or errors are seen when using application, there are several possible causes.  

This document describes a number of troubleshooting steps and possible solutions. 

 

 

Checklist 

1. Ensure the Computer Satisfies the Application’s Pre-Requisites 

 

Read the XLfit Install Guide (See XLfit 4.3, XLfit 5 or XLfit 5.3) document for the pre-installation tasks 

and minimum requirements.  

XLfit 5.3 requires Windows XP, Vista or 7, Office 2003, 2007 or 2010 and .NET Framework 2.0 SP1.  

For a list of supported platforms for all version of XLfit, check the Software Platform Support 

document (page 13). 

If a 64 bit operating system is required, only Windows 7 is supported; 64 bit Office 2010 is now 

supported on XLfit 5.3 (this requires a separate installer). 

The latest versions of XLfit 4 and 5 are available to download from the XLfit Support Portal. 

Please note the IDBS Help Desk can only assist when XLfit is installed on a supported and tested 

environment. 

 

2. Check the Installer and User’s Windows Permissions 

 

Ensure the application has been installed as the Administrator on the computer, as the XLfit installer 

requires access to the Windows Registry and certain system folders. 

The user running the software must have sufficient Windows privileges to run the application. The 

minimum required permissions are available in the Windows “Users” group. 

A user profile created from a custom-generated group may not contain the user permissions required 
for successful launching of the application. 

  

http://www.excelcurvefitting.com/sw/xlfitwss/content/Products/Documentation/XLfit43/XLfit43InstallGuide.pdf
http://www.excelcurvefitting.com/sw/xlfitwss/content/Products/Documentation/XLfit5/XLfit5InstallGuide.pdf
http://www.excelcurvefitting.com/sw/xlfitwss/content/Products/Documentation/XLfit5/XLfit5InstallGuide.pdfhttp:/www.excelcurvefitting.com/sw/xlfitwss/content/Products/Documentation/XLfit53/XLfit53InstallGuide.pdf
http://idbssupport.com/sw/selfservice/content/Documents/IDBSSoftwareplatformsupport.pdf
http://www.excelcurvefitting.com/sw/xlfitwss/
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3. Run XLfit from the “Launch XLfit” Shortcut in the Windows Start Menu 

 

Load XLfit by using the shortcut in Start > All Programs > IDBS Software > XLfit5 > Launch XLfit: 

 

  (Windows 7 shown) 

 

This procedure will copy the XLA files required for the application from the XLfit program files 

(default location is C:\Program Files\IDBS\XLfit5) to the correct file locations: 

 XLfitRun.xla is copied to %APPDATA%\Microsoft\Excel\XLSTART 

 XLfit4.xla, XLfit4Chart3D and XLfitForms.xla are copied to C:\ Program Files\Microsoft 

Office\Office1x\Library (where x=1 for Office 2003, 2 for Office 2007 and 4 for Office 2010) 

 

The application will then load Excel and XLfit. This step should be run by all first-time users of the 

application on a computer. 

This should also be carried out by all users when upgrading from a previous version of XLfit, as the 

users’ profile may still include an earlier version of XLfitRun.xla. 

 

If XLfit is installed on a Citrix environment with application sharing enabled, the “Launch XLfit” 

application can be set up as a shortcut. The executable “IDBS_XLfitStart.exe” can be found in the 

XLfit Program Files folder (e.g. C:\Program Files\IDBS\XLfit5), and should be used the first time the 

user needs to use XLfit: 
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4. Temporarily Remove Any Third-Party Add-ins From Excel 

 

We have seen certain third-party add-ins that can cause conflict with XLfit and can lead to problems 

in loading the XLfit toolbar/ribbon or that prevent certain functions from running. These add-ins 

include: 

 Adobe Acrobat PDFMaker 

 ISIS for Excel 

 Accord for Excel 

 Microsoft Euro Currency Tools 

 

Remove these from Excel using the manufacturer’s instructions, and then run XLfit from the Launch 

XLfit shortcut (see step 3). Also remove all other Microsoft add-ins temporarily if the problem is not 

resolved. 

Once the XLfit toolbar/ribbon appears, reintroduce the add-ins to find which is causing the conflict. 

 

5. Re-Enable Any XLfit Disabled Add-ins in Excel 

 

Excel may disable XLfit add-ins if the application had to close unexpectedly – any add-in that was 

running at the time may be disabled to prevent them from loading, in case they were the cause of the 

problem. These need to be re-enabled.  

The location of the Disabled Items is different in between Office versions. Please follow the 

appropriate guide in this document by selecting the appropriate link below: 

 

 Office 2003 

 Office 2007 

 Office 2010 
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6. For Office 2003, Check Windows Update KB907417 is Installed 

 

This update is essential, as it will correct a problem where an add-in may not load if it uses .NET 2.0. 

Without this update, the XLfit toolbar (built using .NET) will not load.  

(Office 2007 and 2010 use ribbons, so these versions are not affected by the problem). 

To check to see if this is installed, open Windows Control Panel, then: 

 For Windows XP, open “Add or Remove Programs”, and then select the “Show Updates” 

checkbox at the top of the dialog box. 

 For Windows 7 or Vista, open “Programs and Features”, and then select “View Installed 

Updates” from the menu on the left. 

Find Microsoft Office 2003 and locate “Update for Office 2003 (KB907417): OTKLOADR”. 

 

If it is not present, it can be installed through Windows Update, or by downloading directly from 

Microsoft. (Please note this update is not included in any Office 2003 service pack.) 

 

7. Delete Office Cached Control Type Library Files  

 

Microsoft Office stores a number of .EXD files in the Windows user profile which caches information 

about Visual Basic ActiveX controls such as RefEdit (see Microsoft KB290537). 

These cached files will be used by XLfit when loading the User Interface Add-in to add ActiveX 

controls to forms like the Fit Designer. If these cached files are invalid, the XLfit Visual Basic code 

cannot be run and an error may be seen (for example, “Object library invalid or contains references 

to object definitions that could not be found”). 

The .EXD files may be invalid if they reference an older version of Excel (e.g. because a new version 

of Office has been installed) or if a Windows Update has been applied (for example, KB957924). 

These files can be safely deleted, as they will be recreated the next time the control is used in Office. 

Close Excel, then either do a search for all .EXD files on the computer, or navigate to the following 

folders, and delete the files: 

 %APPDATA%\Microsoft\Forms 

 %TEMP%\VBE 

http://www.microsoft.com/downloads/en/details.aspx?FamilyID=1b0bfb35-c252-43cc-8a2a-6a64d6ac4670
http://support.microsoft.com/kb/290537
http://support.microsoft.com/kb/957924/en-us
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8. Delete the Excel Toolbar and Menu Settings File 

 

Excel stores the user settings for the configuration of the toolbars, ribbons and menus in an .XLB file 

in the user’s Windows profile. This file can become corrupted, so it can be deleted and Excel will 

recreate the file the next time it is loaded. 

Close Excel then either search the computer for .XLB files, or navigate to: 

 %APPDATA%\Microsoft\Excel 

Make a back up of the file, and then delete it. If the XLfit problem is not resolved, the backup copy 

can be restored. 

 

9. Run Excel Diagnostics (Office 2003 and 2007 only) 

 

Office 2003 and 2007 comes with an in-built diagnostic tool which can repair issues with Excel. 

These can fix minor issues with the Office installation. (For Office 2010, see the next section). 

Run diagnostics as follows: 

 Office 2003: go to Help > Detect and Repair 

 Office 2007: select the Office button, click Excel Options. Go to Resources and select 

“Diagnose”. 

 

10. Repair the Office Installation 

 

XLfit may not run correctly because the Microsoft Office installation is incomplete or damaged. 

Running a repair of Office may fix the problem in XLfit. Please note this is likely to require 

Administrator permissions and possibly access to the original Office install files. 

In Windows Control Panel, open “Add or Remove Programs” (Windows XP) or “Programs and 

Features” (Windows 7 or Vista) and locate Microsoft Office. 

 For “Microsoft Office Professional Edition 2003”, select “Change” then choose “Reinstall 

or Repair” and “Detect and Repair errors in my Office installation” from the Office Setup 

dialog. 
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 For “Microsoft Office Enterprise 2007”, select “Change” and choose “Repair” from the 

Office setup dialog. 

 For “Microsoft Office Professional Plus 2010”, select “Change” and select “Repair” from 

the Office setup dialog. 

 

11. Completely Uninstall XLfit, Then Reinstall 

 

Removing all traces of the original install and then reinstalling the application can solve the problem. 

This is especially appropriate when upgrading XLfit – all traces of the previous version should be 

removed before installing the new version. 

Click here for a comprehensive uninstall guide. 

 

 

If further assistance is required, please contact the IDBS Help Desk. 

Sign up to the XLfit Support Portal to find answers to frequently asked questions in the KnowledgeBase and 

to download the latest version of XLfit. 

  

http://idbssupport.com/sw/selfservice/content/popups/KnowledgeBase/TechDocs/XLfit%20Removal%20Document.PDF
http://www.idbs.com/support
http://www.excelcurvefitting.com/sw/xlfitwss/
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Office 2003 Disabled Items 

a. In the menu bar, select Help > About Microsoft Office Excel. 

 

 

b. In the “About Microsoft Excel” dialog, select “Disabled Items...” 
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c. Select any items in the Disabled Items dialog with the name “XLfit”, then press “Enable”. 

 

 

d. Click “Close” to dismiss the dialog box. 

 

e. Close Excel and restart XLfit using the Launch XLfit shortcut in the Start menu (see Step 3 in the 

Checklist). 
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Office 2007 Disabled Items 

a. Click the Office button. 

 

 

 

b. Select “Excel Options”. 
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c. In the Excel Options dialog box, select “Add-Ins” from the left-hand menu. 

 

 

d. In the “Manage” section at the bottom of the window, choose “Disabled Items” from the drop-down 

list and select “Go...” 

 

 

e. Select any items in the Disabled Items dialog with the name “XLfit”, then press “Enable”. 
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f. Click “Close” to dismiss the dialog box. 

 

g. Close Excel and restart XLfit using the Launch XLfit shortcut in the Start menu (see Step 3 in the 

Checklist). 
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Office 2010 Disabled Items 

a. Select File > Options. 

 

 

b. Select “Add-Ins” 
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c. In the “Manage” section at the bottom of the window, choose “Disabled Items” from the drop-down 

list and select “Go...” 

 

 

d. Select any items in the Disabled Items dialog with the name “XLfit”, then press “Enable”. 

 

 

 

e. Click “Close” to dismiss the dialog box. 

 

f. Close Excel and restart XLfit using the Launch XLfit shortcut in the Start menu (see Step 3 in the 

Checklist). 

 


